
BANNER 

Introduction to Banner 7: 

Banner is an administrative software application  developed specifically for higher education. Banner is used by the university to organize student 
information and conduct university operations. These processes include creating catalogs, scheduling classes, admitting, advising and registering 
students, recording grades, organizing commencement activities and storing student records. Banner is also used to maintain the university’s 
student accounting information. 

Using the metaphor of a paper-based filing system is helpful in visualizing how BANNER and other database applications work. For example, each 
student has a file, and there are multiple forms in each file. On each form, there are different fields of information, such as the student’s last name 
and the student’s social security number. In a paper filing system, the last name and other fields of information about the student may be written on 
every form in the file. But in a database, those fields are only entered when the file is originally established. At that point, the software application 
can automatically collate the student’s information for the user, eliminating much of the redundancy found in paper-based systems. 

In addition, the computer database system allows multiple users to access the same file simultaneously, without fear of losing the file or a specific 
form inside that file. Finally, in a computer database, specific access rules can be set up so that users can be assigned access to the information they 
need and restricted from information they do not need. 

It consists of the below integrated systems:  

FLEXIBLE REGISTRATION 
FINANCE SYSTEM MENU  
HUMAN RESOURCES  
STUDENT  
FINANCIAL AID SYSTEM MENU   
HUMAN RESOURCES 
GENERAL 
BANNER SECURITY 

 

How to Access Banner7: 

1. Navigate to https://banner.utoledo.edu/forms/frmservlet?config=PROD  

2. If it prompts to run java script, say ‘yes’ or ‘run on this site’. 

3. The below screen appears requesting username and password. 

 
4. Enter the username and password in order to login as shown below: 

http://www.easternct.edu/banner/what_is_banner.htm
https://banner.utoledo.edu/forms/frmservlet?config=PROD
http://www.easternct.edu/banner/what_is_banner.htm


 
5. Click on ‘connect’. 

Note: Banner database has different password, it’s not the same as UTAD or SQL Developer. 

Leave the Database value i.e., blank. 

6. You are now logged into Banner. 

 

Using Banner 7: 

While you are using Banner, two windows will be open in your web browser. Both windows must be kept open to use the application. One 

window will be blank – this window will be running the java script (step 2 of login). The other window is the application window, where you 

actually be working on Banner. 

 



 

 

Logging Off of Banner: 

Banner has an inactive timeout feature – so when you are finished, do not leave session open with data that has not been saved, as it will 

be lost.  

 To log off of Banner, close all forms first by clicking the Exit toolbar button.  Just look for the big  

 

 
 

 When all forms are closed, you will be at the Main Menu. 
 

 Click on the  again and you will see a dialog box. Click 
 

o Yes and Banner will close down. 

 
 

 Close any remaining Banner 7 related windows 
 

Banner Navigation: 

The Banner Main Menu will be displayed after successfully logging on to Banner. You may navigate to the desired from by using 
Banner’s menu or by Direct Access. 

 
Banner Navigation Methods: 

There are several ways to access Banner forms. They include: 

• Menu navigation 

• Direct Access 

• Object Search 

• My Banner 

• Site Map 

• Options Menu 

 
Menu Navigation 

Menu navigation is choosing a form from the Main Menu. The Main menu is an arrangement of Banner objects (forms, menus, 
etc...) in a logical hierarchy, by system and then by module. 
 

To open a system menu, double-click on the closed folder icon next to the menu name. A list of module menus for that system will 
appear. Underneath the module, menus are submenus or list of forms. Once you see the form that you wish to access, double-click the 
name of the form. 
NOTE:  You will only see the names of the forms to which you have security access. 



 
 

  

Direct Access: 

 
Direct Access is entering the name of the form or process in the Go 

field of the Main Menu. When the Main Menu is open, your cursor will 

automatically be in the Go field. 

Simply type in the name of the form or process and press Enter on your keyboard.You can also access forms using Direct Access if you are 

not in the Main Menu. Have a record active in the Key Block and then press the [F5] function key, enter the name of the form, and press 

ENTER. You will be taken to the form you chose (if you have access to that form). 

Object Search: 

Performing an Object Search allows you to search for a form without having to know the entire form name. For instance, because many 

Student forms begin with an S, and since Admissions module forms have a second character of A in the form name, you could perform an 

object search on [SA] using the criteria and wildcard %.  

To perform an Object Search: 

1. From the Main Menu, double-click the ‘Go To…’ field. 

2. To perform an object search from another form within Banner, choose File > Object Search. 

 

3. On the Object Search Form (GUIOBJS), enter the criteria in the appropriate fields(s). 

4. Press F8 on the keyboard (this executes the query).  

5. Scroll down to find the form you want. 

6. Double-click within the desired form’s Name field to access the form. 

7. The selected form appears. 



 

  

Banner Form Design 

Banner is composed of forms.  Forms are what might be referred to as screens or windows. Think of Banner forms as paper forms. 

Each form represents a specific body of information, such as a name and address form or class schedule form. 

 

Every form has the following parts: 

 

• Menu Bar 
• Tool Bar 

• Title Block 

• Blocks 

• Auto Hint 

• Status Line. 

 

Every form has a unique 7-character name (e.g. SPAIDEN) and a description of the form (e.g. General Person Identification 
Form). For information about how Banner forms are named, see Appendix A on Banner Naming Conventions. 
The title bar of all Banner forms shows the form name, description, version number, and database 

 

 
 

Information in Banner Forms, like paper forms, is arranged in blocks. Understanding Banner navigation and the many 

functions a form has will help you in retrieving data. 



   

Site Map: 

The Site Map provides an all-encompassing look at the Banner menus. The site map is accessible by selecting the site map link 

 from the main menu. It will list top–level menus and one level below them. No fields are listed, just links to various menus. 

  

Using the Site Map: 

If you select a product from the site map the main menu displays the product you selected with one level expanded. If you select a form or 

a process, it will be displayed. 

Options Menu: 



 

 

 

 

The options menu of each form contains quick links to block on that form as well as to related forms. When the choice in the options menu 

links to another form, that form’s name will be in brackets after the description. As an example, here is the options menu for SPAIDEN, 

General Person Identification form. 

  

Right-Click Function: 

Right click your mouse in non-field white space. 

On most forms, after the form has been filled out with data and you are out of the 

Key Block area, you can use your mouse and right click to bring up a menu that 

will show the same information as the Options Menu. 
 

Without moving your mouse to the toolbar, it will also let you: 

 

• Rollback 

• Save 

• Exit 

• Print 



 
 

 
 

 
 

 
 

Menu Bar:  

 
 
 
 
 

Every form in Banner contains a menu bar. The menu bar provides an alternative method of navigating through 

Banner. 

• If a menu or a selection on a menu is dimmed, then it means that it is disabled. 

• If a menu or menu selection is disabled, you cannot select it at that time. 

To close a form in Banner, you must click the Exit button  on the toolbar, or select File > Exit from the menu bar. 
Toolbar Buttons: 

  

Banner toolbars contain sets of iconic buttons that perform common functions. ToolTips appear as you move the 
mouse pointer slowly over the buttons. 

      Save – Saves all changes entered since the last time you saved. [F10] 

Rollback – Clears all information (except key info) and returns you to the first field in the Key Block. On query       
forms it returns you to the first field on the form [Shift F7] 

 

Select – Selects a field and enters value into form [Shift F3] 
 

Insert – Inserts a new blank record 
 

Remove – Removes the hi-lighted record from the record. When you Save, the removed information is deleted        

from the system. 

 

      Previous – Moves the cursor to the first enterable field in the previous record [Up arrow] 

Next – Moves the cursor to the first enterable field in the next record of the current block. If the cursor is in the      
last field, a new field is created. [Down arrow] 

 

Next Block – Moves the cursor to the next block. If the next area is in another window, that window will open. 

      [Ctrl Page Down]
 

 

Previous Block – Moves the cursor to the previous block. If the previous block is another window, that window       

will open. [Ctrl Page Up] 

 

Query Enter – Puts the form into query mode so you can enter search criteria to see what information is already in the 

database. 
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Query Execute – Searches the database and displays the first set of records that matches your search 
criteria 

[F8] 

Query Cancel – Cancels the query and takes the form out of query mode [Ctrl Q] 

 

View/Send Message –Takes you to the GUAMESG form to view or send out message through Banner 

 

Print – Prints the current window with the date and time in the title bar [Shift F8] 

 

 

Key Blocks: 

Each form has one Key Block, usually the first block on most forms. (Some forms especially validation 
table forms and certain list forms, do not have a Key Block.) The Key Block contains information that makes 
each record unique. 

 
For instance, on a class roster form, the Key Block contains the term and the course reference number (CRN). The 
Key Block on an identification form contains the person’s name and ID number. 

 

The Key Block determines what is entered or displayed on the rest of the form. All information on the form refers 
to the Key Block data. The Key Block stays on the form as subsequent blocks appear, though occasionally, 
another window may appear on top of the Key Block if the window is unusually large or the Key Block is not 
pertinent to the window. 

To change information in the Key Block (i.e. to access another record); you must click on the Rollback button 

 . 
 
 

Other Blocks: 

Each record will have one or more other blocks. Most blocks have a title. There are two exceptions: 

• If a form or window has only one block, the block does not have a title. 
 

• If a form has a Key Block and only one other block, the second block does not have a title. 
 
 

 

Fields: 

Within a block, the labeled spaces are called fields. Examples of fields are Last Name, Address, Phone No., 

Course Reference Number, Term Code, etc. 

Note: A field is sometimes called an item. This is the case in the names functions Next Item, Previous Item, and 

Duplicate Item. 

 

 

Values: 

Data that are entered or displayed in a field are called values. Values are either free-format or come from a 

list on a validation table form (LOV). 

Examples of free-format or variable values are names and street addresses. They can be typed in freely and are 
not tested against a set of table values. 

 

List of Values 

Many fields only accept codes from a defined List of Values (LOV). Banner 7 no longer has blue fields, 

the presence of predefined values are indicated by the appearance of an arrow down button.  

 

Codes and associated descriptions in a LOV are defined on a validation form. Some validation forms 

contain more than just the valid codes and their associated descriptions. 
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The Code/description lookup feature helps you enter information into validated fields. 

• Look up a code/description based on a partial entry 

• Enter a complete code or description 

• Display the entire LOV and select a code. 
 
 

Enter a complete code or description in a field with a            button 

 

1. Enter the full code (for example, Y) or full description (for example, Citizen). 

Press ENTER. The code and description appear. Depending on the field, the cursor may automatically skip to 

the next field. 
 

Display the entire LOV for a field with a         button 

1. Double Click the field. 

2.   Note: If you are on a form that was called by another form, press the CTRL key before you double-

click. (Double-clicking, by itself, selects a value rather than displaying an LOV.) 

3.   If more than one form or window is associated with the field, an Option List appears. Usually, the 

first option displays the LOV. Otherwise, the LOV appears automatically. Scroll (if necessary) to the 

desired value in the LOV. 

4.   Double-click the value. The LOV closes, and the selected value is returned to the code field. 

 

Note: If double-clicking the field does not bring up the LOV, then click inside the field and choose Help > List. 

 

To refine your search in a LOV or Search Results window: 

 

1. Click on the Find field in the LOV or Search Results window. 

2.   Enter the search criteria 

3.   Use the wildcard % to represent any number or unspecified characters 

4.   Use the wildcard _ to represent one occurrence of an unspecified character. You can use both 

wildcards in the same search string. 

Examples: 
A% to search for all codes and descriptions that start with “A” 

_AID   to search for all four-character codes that end with “AID” 

5.   Click the Find button or press ENTER 
 
 

 

Records 

A record is a group of fields that make up a logical unit. An address record, for example, is made up of 
several fields: Street Address, City, State and Zip code. A person may have multiple address records, (PR 
permanent, MA mailing). Some records are displayed as lists; for example, a class roster is a multi-record list 
with Name, ID number, Registration Status, and other fields as the components of the record. 
 

Auto Hint and Status Line 
 
 
 

 
 

Auto Hint 

The Auto Hint at the bottom of the form may contain the following information for the field where the cursor is 

located: 

• Brief field description 
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• Error and processing messages 

• Keyboard shortcuts 

• Instructions for access other blocks, windows, or forms from the field 

 

Tip: If you have typed something that is not allowed in the field, read the message on the Auto Hint line. To 

clear the message, select the Help button once; this will re-display the original information about that field. 

Status Line 

 

The Status Line directly under the Auto Hint can contain one or more of the following messages: 

 

• Record n/n: Shows the number of the current record followed by the total number of records in the 
current block. If there are more records than fit in the window, the total appears as a question mark 
(for example, 3/?) until you scroll to the last record in the block. Once the last record is displayed, 
the total appears as a number (for example, 3/15) 

• List of Values: Indicates the field has a List of Values 

• Enter-Query: Indicates the form is in query mode. 
 
 

Validation Forms 

 

 

When entering information on an application form, there is sometimes a List of Values (LOV) 
where only specific data can be entered. 

 

That data is usually in the form of codes or abbreviations that are set up and defined in validation forms. To 

view a validation form directly from a field, perform a List command (double-click the field or choose Help > 

List). 

 
 

 

Those values under Code are the only values that will be accepted in the field. These fields are maintained by the 

Functional Area Expert from the respective area that supports this module. 

 

 

 

 

 

 

Additional Banner Features 
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Calendar   

 

Click on the calendar icon or double-click in any date field to display 
a calendar. If the date field has a value, the 
calendar highlights that date. If the date field 
is empty, the calendar highlights the current 
date. You can double-click a date on the 
calendar to return it to the calling form. You 
can also click the Today button on the 
calendar to select today’s date. 

 

Calculator 

 

Double-click any amount field to display the calculator. If the amount field 

has a value, the calculator shows that amount. Make necessary calculations. When 

you are done, click the OK button to return to the calculated value to the calling 

form. 

 
  

 
 


